Jump to content


- - - - -

CD-ROM drive error


  • This topic is locked This topic is locked
34 replies to this topic

#1 Guest_Guest_Matt_*

Guest_Guest_Matt_*
  • Guests

Posted 06 June 2004 - 09:58 PM

Just recently i've started having trouble with my CD drives. I can read and write data to CD's fine but whenever i try to play games such as WC3 and Diablo 2, it says to place the CD in the drive. The problem is that they are in there. I can explore the data on the CD so i know it's not something wrong with them. Anyone else have this problem? If so, how did you solve it? I'm using windows XP Pro.

#2 Guest_BOB_*

Guest_BOB_*
  • Guests

Posted 14 June 2004 - 08:06 PM

Just recently i've started having trouble with my CD drives. I can read and write data to CD's fine but whenever i try to play games such as WC3 and Diablo 2, it says to place the CD in the drive. The problem is that they are in there. I can explore the data on the CD so i know it's not something wrong with them. Anyone else have this problem? If so, how did you solve it? I'm using windows XP Pro.

HAVE EXACTLY THE SAME PROBLEM....ANY ANSWER SOMEONE

#3 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 09 July 2004 - 07:00 PM

GRRRRR...im having the same problem as we speak!!!! JESUS it is very Frustrating!

#4 Guest_Diablo II fan_*

Guest_Diablo II fan_*
  • Guests

Posted 11 July 2004 - 02:12 PM

:unsure: I have the same problem. hope someone finds out soon.
If I find out - I will tell :)

#5 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 15 July 2004 - 09:31 PM

[censored] [censored] [censored]

exactly the same thing for me with WC3 and diablo2 now!!

i was just looking on the internet for it and it bring me here

#6 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 19 July 2004 - 06:03 PM

me too hha

#7 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 22 July 2004 - 01:05 PM

hi guys

the only way i found right now too make it work is too uninstall my cd-rom then reboot my computer so it found it by itself

then it work but not for too long

i have no idea what it can be
ill try too find new driver for my cd-rom and look if it change something

good luck

#8 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 13 August 2004 - 01:11 PM

i have the same problem... any solutions????

#9 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 29 August 2004 - 02:40 PM

Hahaha! I just searched the net, im having same problem with diablo 2, and it brought me here as well...

#10 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 11 September 2004 - 09:17 AM

yeh im geting the same and i cant get it to work might be somthing wrong with wc3 i have 98 and only just started geting the error :(

#11 Guest_Xakanis_*

Guest_Xakanis_*
  • Guests

Posted 19 September 2004 - 04:44 PM

I had this problem but i fixed it temporarily by making a virtual cd rom with alcohol 120% (cd emulator), but then after a day i get the cd rom drive error and it can't detect the F*cking CD. GOd someone help

#12 Guest_loucifer_*

Guest_loucifer_*
  • Guests

Posted 25 September 2004 - 01:03 PM

Yep same problem. Ive tried everything, even new power supply, ide cables,motherboard, cd drives, and drivers. Nothing works. I was playing diablo 2 when this happened 2 weeks ago. I can get the cd to explore but when I want to play a game it says either 'please insert cd' or '/drive not accessible.' This is a pain in the a**. Maybe a new virus? Hope not, norton 2003 says no virus.....

#13 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 01 October 2004 - 05:59 AM

hi i posted hear awhile ago and im happy to say i have my wc3 working fine for me it was a virus i have norton on now and i keep it on and every game runs fine try it might work for you :D

#14 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 04 October 2004 - 10:49 PM

wat was the name of the virus and how could we get rid of it?

#15 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 09 October 2004 - 07:44 PM

Baaaahhhhhhh!!! It's the same for me as well, and I keep running around online to find the same lack of response from techies all over the place. I'm running XP Pro and trying to make D2 work. It should....it really should, but it doesn't. I've tried a few virus scans and I wonder if it's something new enough that they're not picking up on it.

I hope someone figures this out soon, 'cause I've been working on it all day to no avail.

#16 Guest_thebear555_*

Guest_thebear555_*
  • Guests

Posted 12 October 2004 - 11:30 AM

I believe it has something to do with the administrative privilages. apparently BLIZZARD say if you are logged on as the administrator there should be no problem. However I am the only one on this computer so i must be the administrator so that can't be right.
The next thing they advise it to change the accessability options. Go to control panel> accessability options> general tab and then check the two boxes where it says administrative options. this worked for me for a while and the game ran fine however they became unchecked and i was unable to keep them re-checked after closing the window. That was several months ago and i have since traded the game in, in fury, because i couldn't play it.

#17 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 16 October 2004 - 07:47 PM

sigh only way i can solve it is to uninstall diablo then reinstall then works.Temp then it has same prob how do we update chip thingy blizzard said that might work

#18 Guest_MItkO_*

Guest_MItkO_*
  • Guests

Posted 17 October 2004 - 02:16 AM

!!!!!! Probelm!!!!!! Please make sure your DIABLO 2 Play Disc is in your CD-ROM drive, then click on "Retry".!!!!!Problem!!!!!!! :( ;)

#19 Guest_foxdie_*

Guest_foxdie_*
  • Guests

Posted 17 October 2004 - 06:35 PM

yep same damn problem :(

#20 Guest_irne_*

Guest_irne_*
  • Guests

Posted 20 October 2004 - 04:41 AM

Some hints:

http://www.blizzard....rt/?id=adt0287p


It can be caused by a virus (I had the same problem a year ago). If your antivirus software doesn't find it install another one.