Jump to content


- - - - -

limited or no connectivity


  • Please log in to reply
74 replies to this topic

#1 Guest_zach_*

Guest_zach_*
  • Guests

Posted 18 September 2004 - 10:22 PM

Ok, I'm sure people have asked for help with this before, but I don't know where else to turn. I have the dreaded "limited or no connectivity" problem that apparently comes with SP2. Although, for most people they can either run the winsock xp fix program or reinstall their winsock registries. Neither of these worked for me. I don't know what else I can do. Thanks.

#2 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 01 October 2004 - 09:39 PM

are you daft?
just go to network connections
right click on lan, properties
and remove check at bottom to notify when limited or no connectivity

#3 Guest_John Doe_*

Guest_John Doe_*
  • Guests

Posted 04 October 2004 - 12:41 PM

Is unchecking the box of "limited or no connectivity" really going to fix the problem? I dont think its that simple. I have yet to see a good fix for this problem. It seems our buddy Microsoft is avoiding the situation at all costs. Isn't that nice :)

While all my clients are calling me day and night, I cant wait any longer for that stupid fix. Im just going to format the HDD and waste 40 hrs of work... all thanks to Microsoft!
Thanks for nothing Billy!

#4 Guest_Sandmoose_*

Guest_Sandmoose_*
  • Guests

Posted 07 October 2004 - 04:10 PM

I reformatted and it still wont work

#5 JMK1956

JMK1956

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 11 October 2004 - 12:06 PM

Still no fix yet, anyone? This problem is making me mad, too!

#6 Guest_rich_*

Guest_rich_*
  • Guests

Posted 11 October 2004 - 12:59 PM

lol whoa i think it worked for me omfg thats stuupid

#7 Guest_techjudge_*

Guest_techjudge_*
  • Guests

Posted 14 October 2004 - 09:23 PM

i have heard a few different fixes for this problem. there is a hot fix from microsoft that will fix or help this. there is also a registry key that needs to be added. *Note, I haven't tried either but just something you could try. There is a patch that i found that is also suppose to fix it. use google and search for it. you will come across it. if you want the links, email me at tech.judgeEmail Removed and i'll send them to you.

#8 Guest_Flipsyde_*

Guest_Flipsyde_*
  • Guests

Posted 15 October 2004 - 10:33 AM

Email you? Wouldn't you be doing alot more help by just posting the info/links you have right here?

#9 Guest_james_*

Guest_james_*
  • Guests

Posted 20 October 2004 - 07:39 PM

seriously, how hard is it to post a link? I believe this is what he is talking about:

http://users.tpg.com...l5muj/index.htm

I tried this as well because I am having the same problem, but i have had no success.

any ideas?

#10 Guest_My Fix_*

Guest_My Fix_*
  • Guests

Posted 21 October 2004 - 06:35 AM

To fix my message I uninstalled the hosts network card and disabled sharing, then reinstalled.

Problem fixed without touching computer with this message.

#11 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 23 October 2004 - 09:38 PM

I just changed my IP address to the 192.168.1.x and this worked.
No need to do anything else.

The main problem is the 169.254.x.x address after installing XP SP2.
For a safer side you can also reset the router (like unplug from wall and plug it in)

Praveen

#12 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 25 October 2004 - 11:08 AM

i'm also having this problem when me and my flatmate are trying to connect our PC's to share a broadband connection. It works fine my end, but his is a brand new laptop he got yestarday so has server pack 2 on it. what should i do? How do i change his IP Address in XP? cheers

#13 Guest_Graham_*

Guest_Graham_*
  • Guests

Posted 27 October 2004 - 12:00 AM

I had this same problem with home hardwired network. Tried all the fixes, MS Patch, regitry update, etc. Would only work after removing network cards and reinstalling in different MB slots. Had to remove tick from checkbox otherwise icon still says limited or no conectivity.
Thanks Bill for a load of rubbish in SP2!

Graham

#14 Guest_Loni_*

Guest_Loni_*
  • Guests

Posted 27 October 2004 - 06:12 PM

I have been dealing with this problem for a while as well. Luckily, the patch and registry change did help here at home on my wireless network. I haven't had the opportunity to try it at work yet. I'll do that tomorrow. Assigning a static IP worked for me at work but that means I have to change my settings when I come home. If you would like to try the patch and registry entry here is the link where I found it.
http://www.pchell.co...nectivity.shtml

Hope this helps someone. :rolleyes:

#15 Guest_Guest_guest_*

Guest_Guest_guest_*
  • Guests

Posted 01 November 2004 - 10:47 PM

Guys and Gals,

here is the fix to the problem...

forget applying the patch fix for SP2

Just uninstall SP2, it really just got the firewall software from Microsoft, not really worth having. As I am sure you would have your own firewall software.

I have a sneaking suspicion that Microsoft has treaked the code for DHCP handling in SP2. So another way to get around this would be to hardcode the IP address of your PC using private IP addresses.

For fool-proof, just use 192.168.0.1~192.168.0.255 with subnet mask 255.255.255.0

Good luck!

#16 Guest_Purple Mike_*

Guest_Purple Mike_*
  • Guests

Posted 03 November 2004 - 11:07 PM

Well you can tell a lot from reading these responses...

I have been dealing with the same issues since updating to SP2. And only one other person noticed the same thing, it seems the DHCP Server isn't working right, or not compatible with something. I have trekked all over the net searching and following every thread.

Many say it worked for me and this and that. Well not here.

The winsocksfix doesn't work...I resetted TCP/IP which microsoft says TCP/IP cant be uninstalled and installed so this resetting of TCP/IP is how they achieve the same action.

The regpatch didn't help.


What I have noticed though, is DHCP isnt working so XP assigns this alternative IP which is how XP knows to display 'Limited or no connectivity'...when it see's that IP a flag goes up and we have a warning.

Though surfing the net with this warning present, my surfing didn't appear to suffer...I went to some sites to benchmark dloading of 200mb files to see xfer rate, and I was doing 378kb /s using a DSL modem.

Manually configuring a static IP works! But really all that is really doing is being as that other address isnt used a flag doesnt go up.

So using 192.168.1.x just lets XP know everything is normal.

BUT, during my escapades in trying to resolve this issue using the winsocksfix and the regpatch and resetting tcp/ip and so on, at one point my surfing capabilities suffered greatly.

Going to google.ca would 50% of the time result in the page could not be loaded...and going to other big pages with java, a lot of the buttons wouldnt load so you had to refresh so that more data would get cached till you could get all the components on that page.

Uninstalling SP2 is a big mistake as you will be exposed to spyware and trojans and virus' that will exploit security vulnerabilities. SP2 patches these security holes.

Besides that isnt a solution, that is avoiding the problem.


My advise, don't play with these winsocksfix and registry patches and tcp/ip reset methods. Don't muck about because nothing is wrong except Microsofts own DHCP server. Just manually configure a static IP.

Right click on your NIC and go properties...select the tcp/ip internet protocol and go properties...on the general tab change the obtain ip address automatically and enter 192.168.1.2 or 192.168.2.2, either is fine, then the subnet 255.255.255.0

Thats it, dont go nowhere else close these and restart so things will be flushed and cleared and surf away.

Go to some broadband ISP site and go to technical support and do a speed test. just to verify everything is okay.


Even if you didn't make a static IP, and your connection warns the 'limited or no connectivity' message and did this speed test, you should find your service is not impaired.

But because DHCP is not working, it's not assigning an IP address, and if one doesn't get assigned then it uses the *damaged line* IP address of 169.254.216.51 and a subnet of 255.255.0.0

Its simply a reflex...simple logic...if DHCP doesn't assign an IP address then it must not be able to communicate with the modem...so the modem or cable must be damaged...but no, not the DHCP itself.

Done!

#17 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 04 November 2004 - 03:42 PM

In the command prompt you could try these commands, type whats between ( )

(netsh int ip reset resetlog.txt)-rebuilds tcp/ip

(ipconfig /flushdns)-flushes the dns
(ipconfig /registerdns)-registers dns, must be done after flushing

These commands may work, also you could try to rebuild the nic.

#18 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 04 November 2004 - 07:43 PM

after applying the post sp2 hotfix, and running the netsh command it resolved my problem. Not quit sure if the patch was even necessary, maybe running netsh by itself would've worked.

The netsh basically reinstalls the TCP/IP Stack.

#19 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 07 November 2004 - 12:07 PM

A very, very big thank you to everyone on this forum who have suggested to make a static IP address!!! I have been playing around with different solutions for over a week now with my wireless network and although some things appeared towork at first, the good ol 'limited or no connectivity' kept coming back...

Just one thing to add: in addition to IP address and subnet mask, make sure you also specify a default gateway (the IP address of your router ie. probably 192.168.1.1). I didn't do this at first and could connect to my router, but not get on the internet. Was very scared at first that this solution didn't work either, but after a bit of playing around it now seems to be fine... fingers crossed.

#20 Guest_Graphit_*

Guest_Graphit_*
  • Guests

Posted 12 November 2004 - 11:02 AM

I experienced the same problems with different machines. One with a Centrino processor, meaning a built-in Intel wireless adapter and another one with a 3Com pcmcia card. The first laptop being Win XP WITH SP2, the second WITHOUT SP2. Even the one without SP2 suffered from the same problem.

I tried all remedies without any luck. The sp2 patch KB884020 with the regfix, resetting IP stack with the netsh.. command. But with no luck. Even configuring my wireless adapters with a fixed IP didn't help.

But, just now, i saw some ligth at the end of (my) tunnel. I changed the SSID of my wireless network and... I was able to connect both machines in no time to the new SSID. Did several repairs and restarts only to find out that IP addresses were being acquired correctly.

Now I even changed back the net SSID to the old one and both portables are able to connect without any problem, properly receiving their IP address from the dhcp server.

I'will keep on diagnosing this problem, and keep my findings posted here.