Jump to content


- - - - -

limited or no connectivity


  • Please log in to reply
74 replies to this topic

#21 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 12 November 2004 - 10:20 PM

I was having the same problems as everyone else... applied hotifx, registry patch, stack reset.... nothing worked.

Then, I changed the name of my wireless network using the router utility. Following this, I ran the wireless wizard on my laptop. I entered the new wireless network name. Whaddayaknow! It worked.

I changed the wireless network name back the way it was previously, re-ran the wireless wizard on the laptop and everything is still working.

HTH
LT

#22 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 13 November 2004 - 05:01 AM

Adding a static ip address will only work if you're behind a router, if you are directly connected to your cable modem or adsl, mosr isp uses dhcp to connect to the internet. so static ip will not work without a router.

#23 Guest_inafunk_*

Guest_inafunk_*
  • Guests

Posted 13 November 2004 - 08:56 AM

Purple Mike,

you rock the house like rock and roll.

thanks,
i.a.f.

#24 Guest_nikos_*

Guest_nikos_*
  • Guests

Posted 15 November 2004 - 07:07 PM

i fixed my problem with the ip adress but i don t know how to fix my broblem to share my internet conection.In my computer i have ip adress 192.168.0.1 and subnet mask
255.255.255.0 and i don t have a default gateway and in the other computer i have ip adress 192.168.0.254 and subnet mask 255.255.255.0 and no default gateway..what i have to do...what numbers i have to put for my gateway

sorry for my english..i am from greece..please help me
my email adress is [email protected]

please HELP!!!

#25 Guest_yOuRmOm_*

Guest_yOuRmOm_*
  • Guests

Posted 18 November 2004 - 12:35 AM

Once again Microsoft pisses the world off! But, do we turn to Apple or Linux? I dont think so... We stick by that multi-colored window logo!

Anyway, like everyone else I have that "limited or no connectivity" ***** problem BUT, all i have heard about this problem is that it is to do with wirless cards, my wireless works fine. My LAN connection is messed up... I tried the fix and reg fix but I do not know what to enter for DNS server settings... HELP PLEASE!

There is no received packets on my LAN connection, only sent packets!!!!







PS: HALF-LIFE 2 ROCKS!

#26 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 18 November 2004 - 04:36 AM

I have this problem too, ARGGHH - Nothing suggested here has worked! Anyone got any more ideas?

#27 Guest_Lalo_*

Guest_Lalo_*
  • Guests

Posted 21 November 2004 - 12:07 PM

ARRRRRRRGH!!!!

Yes, I have tried everything listed above in this forum and a dozen other forums. My problem is with cabled LAN (wireless is still okay). Everything was fine after SP2 until a week ago when LAN stopped working. Since I did not recently install any patches/fixes from MS site how could it be a problem with SP2?

Anyone heard of a virus that messes with TCP/IP settings, etc???

#28 Guest_spartanrob_*

Guest_spartanrob_*
  • Guests

Posted 29 November 2004 - 09:04 PM

ARRRRRRRGH!!!!

Yes, I have tried everything listed above in this forum and a dozen other forums. My problem is with cabled LAN (wireless is still okay). Everything was fine after SP2 until a week ago when LAN stopped working. Since I did not recently install any patches/fixes from MS site how could it be a problem with SP2?

Anyone heard of a virus that messes with TCP/IP settings, etc???

Same problem, wired only, works fine wirelessly. Need help, please

#29 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 04 December 2004 - 01:42 PM

Thank you Purple Mike.

Before reading your post I had tried the hotfix, reg patch etc with no luck. Then I did what you said, configured the IP addresses manually and I was back in business!

Cheers!

#30 Guest_Sheero_*

Guest_Sheero_*
  • Guests

Posted 04 December 2004 - 07:44 PM

Yay, my uncle told me exactly what to do.

To fix it you have to:

1.Somehow get a program that handles wireless connections
ex.Wireless USB 2.0 WLAN Card Utility

2.Right-click your connection, click Properties, click wireless connections and uncheck
the box that says "Use Windows to configure my wireless network settings.


Only for non-encryption users.
3A.Just tell your 3rd party program to handle the connections and it will work.

Only for WEP encryption users.
3B.Using your 3rd party program, configure the wireless connection's encryption so that you enter a passphrase (WEP Only).

I hope this works for you because it worked for me! lol.

#31 Guest_Nighthand_*

Guest_Nighthand_*
  • Guests

Posted 05 December 2004 - 04:13 PM

Alright...

I have the same problem. I've tried everything short of uninstalling SP2 (which i'd much rather not have to resort to) Hotfix, all that, nothing worked.

Came here, started reading through this. Purple Mike's post about the IP i tried. RAY OF HOPE! instead of no connectivity, it says connected!

but no, it still doesn't work. it sends packets, but doesn't recieve them.

my setup: DSL comes in via it's modem. That hooks up to a linksys router. The router then splits the connection; one to my dad's desktop, one to a currently unuse and unconnected cord (which i'm using temporarily to get on. Surprisingly, the hard line here works, but the wireless still doesn't.) the other port of the router goes to a linksys wireless access point.

Normally, my mom on her laptop, my brother on his desktop with a USB wireless adapter, and myself on my laptop all connect wirelessly. in the past it's worked fine. It worked fine for months after i installed SP2.

Now the odd things come in.

My dad, upon getting his new computer, took over the router. he changed the name and password so that only HE can access it, and he refuses to tell anyone else.

My dad doesn't talk to me anymore due to family things, so i can't ask him to do anything, and can't access the router. resetting at the moment is out of the question. however, my dad turns off the power strip in there each night, turning off the DSL modem, router, and access point.

Now, with four computers on the network, only one is affected by this lack of connection at a time. It started happening about a month ago, circumstances led me to think it was my dad's attempts to keep me from using the net. it appears to only hit the fourth computer to log onto the network. first my mom, then my brother, then my dad, and then finally due to a late get up this morning, me.

again, it's just the wireless not working for me, the wired is working fine. not sure what this may have to do with.

I've tried various IPs, but none that i've tried work. here's the list of settings:

IPs tried: 192.168.1.104, 192.168.1.99, 192.168.1.255, 192.168.2.2, 192.168.1.2
subnet mask: default at 255.255.255.0
gateway: Initially blank, upon reading further posts was set to the router's 192.168.1.1

DNS server settings left blank, because i have no clue what to put there.

now, i'm 99% sure that turning off the power and resetting it would solve this, but that's only a temporary fix; the fourth one to sign on would still be hit. i COULD ignore it and be greedy as the first on, but eventually it would be reset and my computer would be a tad slow, or whatever, and i'd be again locked out. so i want to know if there's anything i can do.

Thanks for reading all this, and for any help you can give...

#32 guestolo

guestolo

    Site Donator

  • Admin
  • PipPipPipPipPipPipPip
  • 16,247 posts

Posted 05 December 2004 - 04:20 PM

Just a question for anyone on wireless and Windows XP
Have you tried going to
START>>>Run>>type in services.msc

On the right hand side look for this service
Wireless Zero Configuration
Double click on it and Stop the service

It may help some out

This needs to be made into an organized sticky

Put Purple Mikes suggestion and a few others
Including Winsock fix
Registry fix

Leave uninstalling SP2 as a last resort


You can also try a repair on the Wireless connection
This is From Microsoft
The Repair capability has been enhanced in Windows XP SP2 for wireless connections. You can access the Repair capability through the Repair context menu option of a connection or from the Repair button on the Support tab of the Status dialog box of a connection. When you repair a wireless connection, it is disabled and re-enabled, which clears many error conditions on wireless network adapters.

Do you want to post your own logs from FRST?
Follow the instructions posted Click Here


#33 Guest_Nighthand_*

Guest_Nighthand_*
  • Guests

Posted 05 December 2004 - 04:35 PM

I use that service to connect to my network, so disabling it kills the wireless altogether. the software that came with the wireless card has never been installed on my machine, i don't think... it's a Dell TrueMobile card, 1150 series by the way

#34 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 06 December 2004 - 05:30 AM

Well you can tell a lot from reading these responses...

I have been dealing with the same issues since updating to SP2. And only one other person noticed the same thing, it seems the DHCP Server isn't working right, or not compatible with something. I have trekked all over the net searching and following every thread.

Many say it worked for me and this and that. Well not here.

The winsocksfix doesn't work...I resetted TCP/IP which microsoft says TCP/IP cant be uninstalled and installed so this resetting of TCP/IP is how they achieve the same action.

The regpatch didn't help.


What I have noticed though, is DHCP isnt working so XP assigns this alternative IP which is how XP knows to display 'Limited or no connectivity'...when it see's that IP a flag goes up and we have a warning.

Though surfing the net with this warning present, my surfing didn't appear to suffer...I went to some sites to benchmark dloading of 200mb files to see xfer rate, and I was doing 378kb /s using a DSL modem.

Manually configuring a static IP works! But really all that is really doing is being as that other address isnt used a flag doesnt go up.

So using 192.168.1.x just lets XP know everything is normal.

BUT, during my escapades in trying to resolve this issue using the winsocksfix and the regpatch and resetting tcp/ip and so on, at one point my surfing capabilities suffered greatly.

Going to google.ca would 50% of the time result in the page could not be loaded...and going to other big pages with java, a lot of the buttons wouldnt load so you had to refresh so that more data would get cached till you could get all the components on that page.

Uninstalling SP2 is a big mistake as you will be exposed to spyware and trojans and virus' that will exploit security vulnerabilities. SP2 patches these security holes.

Besides that isnt a solution, that is avoiding the problem.


My advise, don't play with these winsocksfix and registry patches and tcp/ip reset methods. Don't muck about because nothing is wrong except Microsofts own DHCP server. Just manually configure a static IP.

Right click on your NIC and go properties...select the tcp/ip internet protocol and go properties...on the general tab change the obtain ip address automatically and enter 192.168.1.2 or 192.168.2.2, either is fine, then the subnet 255.255.255.0

Thats it, dont go nowhere else close these and restart so things will be flushed and cleared and surf away.

Go to some broadband ISP site and go to technical support and do a speed test. just to verify everything is okay.


Even if you didn't make a static IP, and your connection warns the 'limited or no connectivity' message and did this speed test, you should find your service is not impaired.

But because DHCP is not working, it's not assigning an IP address, and if one doesn't get assigned then it uses the *damaged line* IP address of 169.254.216.51 and a subnet of 255.255.0.0

Its simply a reflex...simple logic...if DHCP doesn't assign an IP address then it must not be able to communicate with the modem...so the modem or cable must be damaged...but no, not the DHCP itself.

Done!

I have tried everything!!! Fixes, patches, anything on the market..! When I assign manually an IP address the connection seems to work fine; I don't get the "limited or no connectivity" message... HOWEVER, the other computers on the network have no Internet..! Anybody any ideas??? <_<

#35 Guest_Nighthand_*

Guest_Nighthand_*
  • Guests

Posted 06 December 2004 - 10:15 AM

One thing I discovere about Purple Mike's solution is in order for it to work, your router either needs to be able to handle one static and other dynamic IPs, or DHCP needs to be turned off altogether and each computer assigned a static IP. In my case I cannot access the router so it doesn't work for me.

#36 Guest_Internet Tech Support_*

Guest_Internet Tech Support_*
  • Guests

Posted 06 December 2004 - 02:14 PM

Microsoft has setup a special FREE :D hotline just for this issue (SP2 update to XP)
It is: 888-SP2-HELP

#37 Guest_jordan_*

Guest_jordan_*
  • Guests

Posted 06 December 2004 - 07:50 PM

don't uninstall SP2

someone on this site suggested it, and since i don't know [censored] about computers i blindly took the guys advice and now my computer can't even boot up... when i try to it just constantly restarts over and over again.

it wasn't until after i starting uninstalling it that i read all the posts from people saying "whatever you do don't uninstall SP2"

well now i have the world's most expensive paper weight... unless anyone can advise me of what to do in a way that i might understand

#38 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 06 December 2004 - 08:58 PM

http://support.micro...=windowsxpsp2kb

If you have your XP Cd not all is lost
If the above link won't help you out and you need a good link to explain how to do a clean install on your computer post back

#39 Guest_Heath_*

Guest_Heath_*
  • Guests

Posted 07 December 2004 - 08:17 AM

I have tried all the fixes and i am still haveing the same problem. Im on a network were i cant set a static ip and all the computers that are hooked strait to a cisco 2950 switch work great but any computers hooked to a hub with more then 30 ft of cat5 give me this error. the ones with less work fine. I have made new cable to see if this fixes it but same results. I have no choice but to use SP2 so i realy need to find a fix.

#40 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 12 December 2004 - 08:04 PM

I had this problem for a week....but only when connecting through a repeating access point (DWL-800+).

Changed the settings to allow UPnP, and it works fine now. The router now shows up as UPNP-NAT Gateway in the "My Network Connections" page. This was on a new Dell laptop w/ sp2 installed.