Jump to content


- - - - -

limited or no connectivity


  • Please log in to reply
74 replies to this topic

#41 Guest_Derrell_*

Guest_Derrell_*
  • Guests

Posted 16 December 2004 - 10:42 AM

I have found that unintalling the NIC, restarting the machine, and then reinstalling it, sometimes works. I also found that if you install a USB NIC it magically works, not to sure about a PCI NIC but, I dont know, I'm just finding work arounds, as far as a solid fix, touche' Microsoft.

#42 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 16 December 2004 - 04:46 PM

Try winsockfix

#43 Guest_Henry Kreitem_*

Guest_Henry Kreitem_*
  • Guests

Posted 18 December 2004 - 09:42 PM

I tried each and every suggestion listed on the last three pages, but none worked for me........ :( Luckily I had the original Windows XP installed on another drive, I went back to it and every thing is back to normal :D .....I will keep checking this board for suggestions........Thanks

#44 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 20 December 2004 - 04:17 AM

:ph34r:
THANX TO MICROSOFT! THEY MADE THIS UP TO MAKE MONEY THUR THEIR TECH SUPPORT GROUP. LIMITED OR NO CONNECTIVITY IS A BIG BUG CREATED BY MICROSOFT.

#45 Guest_Takean_*

Guest_Takean_*
  • Guests

Posted 20 December 2004 - 11:52 PM

Plz check out this. I found this and it helped me a ton!!! I had the same problem as you all did, but it was only after I ran Adaware on my wife's laptop to clean it out. Upon restart, all I could get was "limited or no connectivity". After reading and searching on my desktop for an answer..I found this:

"Limited or No Connectivity Error
Today, I spent a few hours helping to clean up a friend's computer that hasn't been serviced in over 2 years. The first thing I did was uninstall the user's non-functioning antivirus program (the definitions had expired several months prior), booted into safe mode and removed a handful of virii using Symantec's Automated Support Assistant. I then installed Norton Antivirus and did a complete scan of the system.

Next step was to check and remove all unwanted startup programs in the registry, in the Startup folder and running services. Silent Runners does a great job of identifying and reporting all Windows startup programs (it's a small effective VB program that uses the WMI). I then installed two spyware removal tools, AdAware and Spybot Search and Destroy. I finished up by cleaning up the Temp and Temporary Internet Files folders and defragging the system using VoptXP (a very fast defrag utility - much faster than dfrg.msc).

After I was done, the internet connection stopped working and I started receiving a "Limited or No Connectivity" error. I tried a variety of strategies including re-installing the network card, checking the physical connections, ect. The culprit was corruption in Winsock and the TCP/IP stack (undoubtedly caused by the spyware). I used the Winsock XP Fix tool to do the repairs (it's actually a VB implementation of the information provided in Microsoft KB article 299357 - How to reset Internet Protocol (TCP/IP) in Windows XP).

Here is a link to the repair program:
http://www.spychecke...nsockxpfix.html
"

I followed via Microsoft's help site...located at:
(How to determine and recover from Winsock2 corruption)
http://support.microsoft.com/kb/811259

I didn't even see the link the other author put at the end of his message until I was already done and got my wife's laptop to work again via the internet. But it works...and I hope this helps you all out..I have seen millions of forums packed with many many ppl asking for help..and I found this..and would feel bad if I didn't share it.

#46 guestolo

guestolo

    Site Donator

  • Admin
  • PipPipPipPipPipPipPip
  • 16,247 posts

Posted 21 December 2004 - 12:46 AM

Thanks for the links Takean, actually Winsock Fix has been mentioned in this thread a number of times
another great utility is LSP fix
Layered Service Provider
Does the same job as Winsock fix but can give you more control in what you want to remove from your LSP settings

Just have to know what your looking for :)

Do you want to post your own logs from FRST?
Follow the instructions posted Click Here


#47 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 21 December 2004 - 04:45 PM

Well, it seems like this problem alway's turns up when i have a problem with my Virus scanner. I user Panda Antivirus, really love the program, always runs fine, but sometimes it give a problem about the proxyserver that's not working, and the program then suggest that i reinstall Panda Antivirus.

Well, by doing that I'm [censored]ing up my whole windows and get this stupid problem, by removing the anti-virus again.. it's fixed again. Really weird, i tried everything what is listed in this 3 pages, but nothing really seems to workout. it's "really" [censored] up if you ask me.

Anywayzz, it works for some time trying allot of things, cause i had this problem before and somehow i fixed it, but now... don't really know. Maybe i'll send a mail to support of Panda software, cause i can't really have my pc without a virusscanner.

#48 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 23 December 2004 - 01:36 AM

;) Limited or no connectivity - I tried the windows fix, the registry fix, the winsocks fix, the static route fix, the turn-off the firewall fix. The only thing that worked for me was the 10/Full fix in control panel-system-hardware-device manager-network adapters; click on properties; advanced; now set to 10 full mode. Even though I have 10/100 network cards I can at least get on my own dad-burn LAN.
Thank you SP2!

#49 Guest_patrick_*

Guest_patrick_*
  • Guests

Posted 26 December 2004 - 04:28 PM

I experienced the same problems with different machines. One with a Centrino processor, meaning a built-in Intel wireless adapter and another one with a 3Com pcmcia card. The first laptop being Win XP WITH SP2, the second WITHOUT SP2. Even the one without SP2 suffered from the same problem.

I tried all remedies without any luck. The sp2 patch KB884020 with the regfix, resetting IP stack with the netsh.. command. But with no luck. Even configuring my wireless adapters with a fixed IP didn't help.

But, just now, i saw some ligth at the end of (my) tunnel.  I changed the SSID of my wireless network and... I was able to connect both machines in no time to the new SSID. Did several repairs and restarts only to find out that IP addresses were being acquired correctly.

Now I even changed back the net SSID to the old one and both portables are able to connect without any problem, properly receiving their IP address from the dhcp server.

I'will keep on diagnosing this problem, and keep my findings posted here.

After hours of pulling my hair out trying all the other solutions posted in this string, this was the light at the end of the tunnel for me as well.

CHANGE THE NAME OF THE NETWORK

Who knew? Why this works and all else failed I do not know.

I was unable to rename my network back to the old name, unfortunately...

Other useful details: I am an ADSL user, with a 56Mb/sec. wireless modem + card from Siemens (mfg by Broadcom apparently).

Hopefully the solution will prove to be stable!

#50 Guest_Derck_*

Guest_Derck_*
  • Guests

Posted 28 December 2004 - 08:28 AM

Winsock fix worked for me! I removed spyware with ad-aware and it [censored] up my tcp/ip !! Thanks!

#51 Guest_George McIntyre_*

Guest_George McIntyre_*
  • Guests

Posted 01 January 2005 - 01:08 PM

I'd had enough of this problem so I decided that I would either work it out once and for all or die trying. I'm not dead.

It appears that WiFi needs to know what network your DHCP server is on *BEFORE* it can communicate with it to get set up on the right network (chicken and egg).

People have suggested setting a fixed IP configuration (which works) but if you frequently travel with your laptop to different WiFi access points you really need DHCP.

So (DRUM ROLL) simply set the default gateway to be the correct one for the DHCP server you want to use. Go to start->control panel->network and internet connections->network connections -> Right click and Properties on the WiFi connection -> Double click Internet Protocol TcpIp item -> click Advanced -> under Default Gateways click Add -> type the new gateway address (eg. 192.168.0.1 or 10.10.0.1) -> OK all the way back to the desktop.

You'll see that now you have a DHCP address and everything works fine.

Note if you use different subnets on each of your different Wireless Access Points you will need to change the default gateway each time. (BTW if you don't understand the last sentence it probably doesn't apply to you)

Enjoy :)
Level 17 - Games Fun Prizes

#52 Guest_Michael Rothwell_*

Guest_Michael Rothwell_*
  • Guests

Posted 02 January 2005 - 09:34 PM

There's a chance this problem is caused by the broken passphrase hashing in SP2.

Try this utility to generate a full WEP key:
http://www.flyingbut...com/wepkey.html

#53 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 07 January 2005 - 12:47 AM

Go to a command prompt window (start > run, then type CMD and hit 'OK') and type the following command:

netsh winsock reset catalog <<and then hit enter>>

It will then tell you that the winsock catalog has been reset all sockets flushed, and proceeds to ask you to restart the PC. Restart the PC and you should be back online!

#54 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 07 January 2005 - 12:47 AM

let me know how it works, lukeywartheadEmail Removed

#55 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 20 January 2005 - 11:49 AM

Hello,

I had tried everything too. Until I read the post mentioning http://www.flyingbut...com/wepkey.html . I only had more time to lose so I tried it. I changed my passphrase (which was only 6 characters long but still worked before sp2) to 13 characters and entered the new 128 bit key in my linksys wrt54 router's config. Then disconnected my wifi, reconnected, entered the new wep key and it worked!!!

I hope this'll help some more people. Thanks to the one who posted this earlier!

#56 Dammaged

Dammaged

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 10 April 2005 - 01:48 PM

2 out of three isn't bad BUT,
I'm running a "LINKSYS"
My main desktop w/ XP Pro SP2 runs fine as does my backup system which also has XP Pro SP2. The problem is my Toshiba Satellite Laptop it still won't connect (or atleast let me on the NET, it does show up on my LINKSYS when plugged in) It is also w/ XP Pro SP2. I've done nothing different on any of the OS installs but the laptop insists on the "Limited or no connectivity" I've pulled the cable connection from either desktop and tried it in the laptop....(I'm not trying to run all three at once.....I only need 2) The laptop won't connect even if plugged in bypassing the LINKSYS...it did connect with a version of XP Home prior to the XP Pro (direct connect not via the Workgroup Switcher).

Additional info: Backup system has an earlier version of XP Pro and was updated with sp2. Main system has a new version of XP Pro that has SP2 already included in the CD. Installed a new XP Pro w/Sp2 on the laptop.
If I plug in the laptop the lights on my LINKSYS show it's connected to the laptop....and when I unplug the cable from the back of the laptop it shows the cable has been pulled. (you get the little X'd computer icon lower right corner.)

#57 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 11 May 2005 - 01:33 AM

check if you still have free ip adress to sign to that pc, becouse then i had that problem i asked my net admin to check it, he said that its possible that it can couse a problem.

#58 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 11 May 2005 - 01:36 AM

i mean that dhcp still has free ip adressess :)

that guest was me too

#59 gokhanaltintas

gokhanaltintas

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 06 June 2005 - 02:56 PM

Why any of you do not try to remove Q