Jump to content


- - - - -

SATA and XP Problems


  • This topic is locked This topic is locked
145 replies to this topic

#41 Guest_Matthew_*

Guest_Matthew_*
  • Guests

Posted 26 December 2003 - 03:16 PM

Hey, I'm still getting some funky errors. When I'm trying to install the drivers, I get the Messaget that the txtsetup.oem is causing can unexpected error 1024 at line 1742 of d:\xpsp1a\base\boot\setup\oemdisk.c. Does this mean that the disk that microsoft provided me is corrupt?

I tried that rdvr way, downloading the drivers, using the CD ASUS sent with...the GUI version and teh SATA directory versions and none of them work.

Thanks for the help...installing windows onto this A7N8X with a Hitachi DeskStar for more than 2 days straight.

#42 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 03 January 2004 - 06:11 PM

Asus a7n8x deluxe. fresh install of win xp. slip disk one of six in,
boot up, hit f6 where it prompts and it skips right on by like I didn't
even hit it. bios set up to boot from floppy, cdrom, scsi. got my five
files on a disk, but no good if f6 is ignored by my computer.
oh well, back to google...

#43 [email protected] giagia_*

[email protected] giagia_*
  • Guests

Posted 06 January 2004 - 09:17 AM

Hi,
I have a new Asus A7N8x Deluxe with the great serial ATA Sil3112a.....
I have read the old posts but don't find a solution for my problem. The situation
is the foolowing:
1- I have installed my system win 2k with the SATA driver;
2- I have installed the drivers for the onboard devices;
3- Installation of many programs without problems;
4- Finally the system run fine!!
but after a lot of reboots a f..king error with the blue screen:

"system registry error
\SystemRoot\System32\Config\SOFTWARE not found or registry item
or the copy is kaputt ...."

How I can access to my HD?
What' is this f..king problem?
I need Help!!!
Thankx
Giagia

#44 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 06 January 2004 - 10:06 AM

I downloaded the drivers from the asus site. (support>a7n8x deluxe). After copying the disks and trying them i got the waring "cannot find setup.oem" or somthing like that. So i now how to solve te prob, its in the manual of the driverpackage, but the disk will not work properly.

HELP!

#45 Guest_Guest AK_*

Guest_Guest AK_*
  • Guests

Posted 07 January 2004 - 11:45 AM

I'm trying to load my SATA driver as well (during my fresh WIn 2K install) - I have all the driver files from Silicon Image, have them copied to a floppy, but I sure as hell can't make the volume label of the floppy "Silicon Image SiI 3x12 RAID Driver Installation Disk", as instructed earlier in this thread. It's an invalid label for a floppy in Win 98, 2K, and XP.
I tried making the floppy label something simple like "SATA driver", but when I hit 's' to offer my driver files, there is nothing found. I'm not even sure why the label is important, as long as you know what it is.
The BIOS on my new a7n8x-e deluxe is ver. 1006 - should I flash to 1007 or 1008 to make this loading experience go easier?

Geezus what an aggravation...
Thanks for any help ...

#46 Guest_Guest AK_*

Guest_Guest AK_*
  • Guests

Posted 07 January 2004 - 03:20 PM

Wow - I misunderstood (as someone else did) about the floppy disk - Since then, I am able to load the SATA RAID drivers no problem (after hitting f6 to load them), but after doing so, my HD isn't being detected as it was before, and I can't partition/load windows. It's as if my mobo jumper to enable/disable the SATA chip is set to "disable" - which it isn't. I've verified it is set to enable (pins 1-2).
When I try to access the RAID utility now by hitting f4 during boot up, it says the utility is disabled. At least when I was trying to get the Silicon Image drivers loaded before, I could always get into the built-in RAID utility (f4 during boot up) and see the HD detected there - now I can't even use this built-in utility.
Ugh - another hurdle to overcome.
Hopefully I don't have bad hardware - I've double checked all my BIOS settings (still have ver. 1006) and can't find any settings to this effect.

Anyone else have this happen?
Regards

#47 Guest_Zimbabwe_*

Guest_Zimbabwe_*
  • Guests

Posted 08 January 2004 - 10:31 PM

I have a Seagate Barracuda 2700.7 120GB hard drive and a ASUS A7V600 motherboard and they connect with SATA and when installing WinXP Pro, it claims there is no hard drive detected and tells me to turn it on. I've never worked with SATA before and I am not a comp genious so any help i can get will be great and please keep it simple.

Oh and when i push F6 on setup, nothing happens.?

Zimbabwe

#48 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 08 January 2004 - 10:39 PM

yes i have the same problem ,,but i am missing this ..silicon Image SiI 3112 SATALink Driver Installation Disk
tried making it from mother board cd rom but the files in drivers folder is incorrect ,, xp comes upwith sataraid not link

dont know what to do , i am using a asus a7n8x mother board and a matrox 80gb sata hard drive

thanx in advance bazzzz99Email Removed

You can't RAID a single drive, so don't enter the Silicon Image BIOS. Just move on.

First, enable the SATA header. Read page 2.7 in the manual. Now boot up and go into BIOS setup. In there, set the third boot device to SCSI - unless there is a "BB" device available to select. That would be it.

I have a single drive and am having problems with the SATA and installing windows XP, if I only have one single drive and am not planning on have more than one in the near future, what can I do to clear up a problem with win setup not recognizing my drive?

#49 Guest_Phil_*

Guest_Phil_*
  • Guests

Posted 10 January 2004 - 08:57 PM

I'm close but not successful yet. I enabled the SATA jumper on the ASUS A7N8X MB, windows XP (already on my non-SATA system drive) saw the new hardware, installed the original Silicon Image 3112 SATA drivers, and it shows up as working in device manager. Parts of XP's computer manager and even the Seagate software see the 160GB drive, but windows explorer and the Seagate formatting software does not. What should I try next ?? I'd appreciate suggestions.

Thanks

#50 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 12 January 2004 - 05:29 AM

I think that there is some bug in sil3112sata drivers, or smth. I have ASUS A7N8X Deluxe, one WD 40Gb Drive connected to the ATA133 bus with XP Pro installed, and Maxtor SATA drive on silicon image as second drive, and had no problems, but when i installed XP on SATA drive, it works normally until i write approx 15Gb of data to the drive. Then i get few times scandisk sessions on boot, a lot of lost clusters, and finally Windows stops booting at all. Then i formated disk and installed XP again, and after adding some gigabytes and rebooting i get scandisk again, but i cancel it everytime before scaning, and computer keeps working well. It is possible, that scandisk, due to some incompatibility, finds problems, which doesn't really exsists, and repairs an healthy disk, but actually corrupts it. A few years ago i had similar problem with Norton disk doctor and some SCSI controllers. Maybe somebody knows a cause and solution?
Thanks

#51 Guest_GSJBoca_*

Guest_GSJBoca_*
  • Guests

Posted 12 January 2004 - 08:48 PM

HI, I had the same problems and solved it by going to the silicon image website and finding the drivers and making the setup disk--works fine. The problme is that on the NVidia CD and website, there are 5 files. On the silcon image site there are 7 files, in addition to the five files listed earlier in this thread, there is a SIISUPP.VXD and a SI3112r.cat file.

You will get a WinXP error 2 or 3 times which says these drivers are crap, but blow through and will be ok--probably says that because the drivers are newer than the WinXP CD.

What a pain, thanks NVidia.

#52 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 16 January 2004 - 06:16 PM

Hi you can download Sata drivers from http://homepage.ntlw..._rdvr-10032.zip

Then do as it is in redme.txt file in that file you downloaded

#53 Guest_fader_*

Guest_fader_*
  • Guests

Posted 19 January 2004 - 10:07 AM

I had 6 drives connected using a raid controller card with standard ide ports. then i added a Sata drive and installed the drivers in XP and it all was well for a few months until i noticed the sata drive was a bit noisy. Then it failed! Then another failed, and another, then finally one more.

That was 450gig gone tits up and i was very sad :( I decided all these drives were creating too much heat and this was my problem. So before i went to buy more drives i fitted a HUGE fan in the front of the box, in front of all the drives, which are hung in a cradle below the existing cradle. I re-built everything except the Sata drive and drivers and all the drives were back to normal funtionality. Yipee :)


As soon as I try connecting the Sata drive everything goes to [censored]. I screws with my USB ADSL Modem too.

I'm guessing it's because i have a Raid controller card in there too. This means i find a solution or i'm stuck at 6 drives.

Any help would be appreciated. Also can anyone tell me why my raid drives are very slow. Thx



fader

#54 Guest_Guest_jack_*

Guest_Guest_jack_*
  • Guests

Posted 20 January 2004 - 10:30 PM

I seem to have the same problem as other people. but I haven't seen the answer.

I have an Asus SK8V motherboard with SATA onboard.

and I installed a Western Digital SATA WD2000 drive. The only ide devices I have are a DVD on one and CD-Rom on the other (both masters)

I configured the hard drive initially with the Western Digital Program prior to installing Windows XP Professional.

When I load Windows XP, it asks for the drives, I press F6 and found the SATA driver on the Asus support disk,

but then XP says that "the hard drive is not detected"

Anyone have the answer to this?

Thanks a lot.

Jack

#55 Guest_Aj_Ream-O_*

Guest_Aj_Ream-O_*
  • Guests

Posted 23 January 2004 - 02:52 AM

I'm looking for the Silicon Image 3112 SATALink Drivers also. Does anyone have a link for me to get them from? I'm about to send an e-mail to tgvirus99Email Removed for them.

hey all. had the same prob as you, but i found the driver you all need. its at:
http://www.asus.com......7N8X-E Deluxe
click on the "drivers" tab, then download the "silicon_v10033.zip" file. in it you will find "Si3112r.inf". thats the driver thats needed. just copy it to a floppy, and after xp install is loading and you hit F6 a few times for good measure when asked, supply that good ol floppy, and youre good to go.

#56 Guest_Aj_Ream-O_*

Guest_Aj_Ream-O_*
  • Guests

Posted 23 January 2004 - 02:54 AM

holy crap i quoted an oooooooold post, hehe

#57 Guest_Guest_Jack_*

Guest_Guest_Jack_*
  • Guests

Posted 23 January 2004 - 02:40 PM

Thanks,
I think I actually solved my problem. I threw in my ide drive from my old computer. Loaded XP. Downloaded the right driver so recognized the SATA drive. Then used the Western Digital Software to partition the SATA and make it the boot drive, moving XP onto it. It boots from there now and works. Of course, I haven't pulled out the IDE drive yet to run it solo (but it is drive F now).

#58 Guest_Gordon_*

Guest_Gordon_*
  • Guests

Posted 26 January 2004 - 05:25 PM

ARRRGH I've just got a new maxtor serial ata 120 gb Diamond Max Plus 9 for my asus a7n8xdeluxe.

Everytime I plug the power in to the old type 4 pin plug the board shuts down and won't boot up. At first thought it was the disk but exchanged it for a new one and same problem again. Tested disk on pc at work a ran fine (i,e did't shut down).

I've set the jumpers to pins 1&2 for enable serial ata on the board.
I've tried loading it with my old ata disk connected.
Tried loading without anything else connected.
Downloaded the latest BIOS (vs 1007 ).
Set first boot device to SCSSI and then changed to 3rd (as mentioned in thread).

On reading the Maxtor manual there are no jumpers that need setting on the disk so am running out of options.

All with same result - MB shuts down after about 2-3 secs, doesn't even get to BIOS post.
Am only running 1 serail ata off primary ata channel
Any idea's anyone. am at wits end and don't want to have to go to asus as support looks ****.

#59 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 26 January 2004 - 07:41 PM

Gordon,

Sounds like your power supply might be overloaded or defective

#60 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 27 January 2004 - 09:22 AM

Hey, I'm still getting some funky errors. When I'm trying to install the drivers, I get the Messaget that the txtsetup.oem is causing can unexpected error 1024 at line 1742 of d:\xpsp1a\base\boot\setup\oemdisk.c. Does this mean that the disk that microsoft provided me is corrupt?

I tried that