Jump to content


Photo
- - - - -

Networking 2 windows xp


  • Please log in to reply
212 replies to this topic

#21 Guest_Guest_Larry_*

Guest_Guest_Larry_*
  • Guests

Posted 03 December 2003 - 05:24 PM

I finally solved the problem on my network!

I uninstalled ZoneAlarm. Even though it wasn't actually running, apparently it still loads something at startup that prevents the networking from working. Some sort of vector monitoring or something. I knew I was on the right track when during the uninstall it warned me that it was shutting something down!

This was after I did Matter Daddy's and Ross' solutions, so I don't know if they were part of my solution or not, but they didn't hurt.

Hope this helps someone who was as frustrated as I was. :unsure:

Good Luck! :P

#22 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 07 December 2003 - 01:10 PM

My problem is similar. I have a home network - a windows xp home machine linked to a windows 98 machine. I can access the 98 machine from the xp machine, but not vice-versa. I can see the xp machine, but not access it. And I was able to send over files and folders from the xp machine to the 98 machine. Now I discover that when I am at the xp machine, and I go to network places in explorer file manager, I cannot access the folders listed there under the xp machine. In other words, I cannot access the xp shared folders even when I am at the xp machine. I can do so if I don't try to do it through the network neighborhood, but not if I do it by going through network neighborhood.

All this leads me to believe that the problem is purely with the xp machine and how it is set up, for some reason. Otherwise, I would be able to access the shared files of the xp machine through network neighborhood while on the xp machine.

I have shut off the firewalls on both machines. I have checked to make sure that the folders have sharing enabled, etc. My setting is "hybrid" (with reference to a previous post here). Browsing is started on "services" on the xp machine, and I changed to netbios over ip etc. as mentioned previously. Nothing works. Weird.

#23 Guest_cprgmr_*

Guest_cprgmr_*
  • Guests

Posted 10 December 2003 - 06:27 PM

I ran into this same problem. Make sure your Internet Connection Firewall is turned off under XP - this fixed it for me. :)

#24 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 12 December 2003 - 01:37 AM

read your post on computing.net. I'm not too sure if you solved it.
I had a similar problem. It took me a whole weekend to fix it. Here's what I did
On the XP machine that does not work.
Try
start
run
command
I have exactly the same problems. I'm sure it has something to do with the DHCP server on my ADSL router not set up properly but the following worked for me. I got this off computing.net

---------------

type ipconfig /all using Comand Prompt
If under node type it says Peer to Peer
Then go to start regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters
Make sure that under DHCP node type (1) not 2 is in brackets. If (2) is present right click and modify it to (1)
Renew the IP
Check Config /all again.
The Node type should now be broadcast
The problem only seemed to be with the PC which booted up last - weird.
Good luck

#25 Guest_Guest_Peter_*

Guest_Guest_Peter_*
  • Guests

Posted 24 December 2003 - 05:16 AM

I finally solved the problem on my network! 

I uninstalled ZoneAlarm. Even though it wasn't actually running, apparently it still loads something at startup that prevents the networking from working. ...
This was after I did Matter Daddy's and Ross' solutions, so I don't know if they were part of my solution or not, but they didn't hurt.


Looks like this problem is solved in many ways, but special thanks to Larry for posting his solution path which matched mine exactly.

I learnt a few things.

(1) search for the specific error message rather than "home network xp win98" or side issues like "Spooler SubSystem App has encountered a problem" both of which lead down to many hours of clicking what should not be clicked.

(2) If I find myself needing to do things to the registry or reflashing a modem to fix a problem, chances are there's a simpler solution.

I loaded ZoneAlarm because I was told I needed it. Like a lot of anti-virus software, it turned out to cost me more time than a virus or even a hack, so I turned it off (XP's Internet Connection Firewall and the modem router seem to cope just fine).

But months later, there it is lurking in the background, completely hidden and causing problems. Who'd have thought? I would not have picked it up but for Larry's posting.

(4) read the whole thread before implementing anything!

(3) posting the solution helps others!


Cheerio.

#26 Guest_alexander_*

Guest_alexander_*
  • Guests

Posted 15 January 2004 - 03:35 PM

1- Open dos prompt, type ipconfig -all.
2- Look at the 'Node Type' it probably says Peer-Peer or something (this is what mine said)
... we want it to say 'Hybrid'
3- Press 'Start' button > Run... > In the box type regedit. This opens your system's registry.
4- Navigate the tree to: HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/NetBT/Parameters
5- Rt. mouse click and select New > DWORD Value
6- Name it 'NodeType' (without the quotes)
7- Rt. mouse click on it and select Modify
8- Set Value Data to '8' (no quotes)
9- Leave Base alone. 'Hexadecimal' should be selected
10- Press 'ok'
11- Close regedit and reboot. (Your done!)
12- Open dos prompt and type ipconfig -all
For node type it should now say 'Hybrid'
13- Do this to the other computer that you cannot network. Your computers should be able to see one another.
----------
I do not know what 'Hybrid' is, but perhaps some of the network freaks might be able to explain. I have used this on two different occasions and it seems to be the only thing that works.

M$ docs refer to 1 as type "B", 2 as type "P", 4 as type "M", and 8 as type "H"
What this basically means is different ways of resolving netbios names.

1 = broadcast. The host sends a broadcast and the nodes which knows the ip of that name answers.
2 = peer. Sends the request directly to a wins server which looks up the name.
4 = multi node. I don't really remember but I think it starts with broadcast and if no answer does a direct lookup from a wins server.
8 = hybrid. Not sure here either, but I think it starts with a direct request to the wins server and if the server is unable to resolve the name it does a broadcast.

cheers&alex

#27 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 17 January 2004 - 03:47 PM

Right lads before you start networking make sure you have all fiewalls turned off, they are a nightmare when networking

#28 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 19 January 2004 - 11:24 PM

Thank you guys. Firewalls off and Netbios over TCP/IP enabled did the trick.

Check out Ross' link on the frist page for a quick check and possible fix.

=)

#29 Guest_Fist of Fury 2k4_*

Guest_Fist of Fury 2k4_*
  • Guests

Posted 20 January 2004 - 06:00 AM

This might be the simple sulution for some of you:-

You can get way too involved in a problem and miss the obvious.....The assumption that everyone knows what NFTS,WINS etc. means would drive you CRAZY.........Microsoft language is so far up their backside normal people cant understand what the heck they are talking about half the time LOL.....before you try any fancy stuff that might lead to you getting into even more trouble do this...............................Go to computer 1 and open control panel and double click "user accounts"..............double click computer administrator (your picture) and then "change my name"........put in the letter........ m.......................go to change my password type in the number 4....................restrt your computer if asked..........................go to computer 2 and do exactly the same.....if given the opportunty tick any box that says remeber my passwrd.......................if this work for you it will automatically let you go from one computer to the other without enterering any name or password.............probably cos they are bothe the same........ who knows.

BTW the letter "m" and number "4" can be changed to anything you like at anytime.

#30 Guest_Anello Giovanni_*

Guest_Anello Giovanni_*
  • Guests

Posted 24 January 2004 - 12:15 AM

Hello,

I have a similar problem. I have 5 computers on a network. Three are running W98 the other two have XP Pro. The network is set up as a peer to peer network. Each of the five computers have identical user accounts and passwords and all have NetBEUI installed. Each computer shows up in the Network Neighborhood/Network Places of all five computers. However, when I try to view shares from the XP boxes it says "Access Denied" but shows the Shares from W98 Boxes fine.

The weird thing about it is if I know the EXACT share names on the XP Boxes and manually enter them in for mapped drives on the other computers, the mappings work fine. As soon as I retrun to Network Neighborhod/Places I get "Access Denied" again. I am currently using the mapped drive workaround but it is a pain to manually map new shares to four different computers.

Anyone have any ideas on how to fix it?

Anello

#31 Guest_MikeC_*

Guest_MikeC_*
  • Guests

Posted 03 February 2004 - 10:28 AM

I have come across this issue setting up windows xp machines often. No matter how many times you run the network wizard it just won't work 50% of the time. But, I did find that if I did a search for the computer name, I found the machine everytime and as long as the folders have shared rights then it was never a problem and I just mapped the folder. This was networked across a linksys router with default settings. Hope this helps
MikeC ;)

#32 Guest_Michael_*

Guest_Michael_*
  • Guests

Posted 04 February 2004 - 11:30 AM

Had the same problem. I have 3 computers networked on a wireless access point. Shared folders show in network places but access was denied. All run windows XP. I turned off zone alarm and now all computers can share.

#33 SirGawain

SirGawain

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 February 2004 - 04:26 AM

PROBLEM SOLVED!!!

After experiencing very similar problems to posts in this and numerous other forums, I finally figured it out: At some stage, the orignal user for whom the computer was setup changed their login name.

The solution:
Assuming all other (obvious) networking issues have been addressed (ie. usernames AND passwords setup for both users on both machines, NetBIOS enabled for TCP/IP, permissions granted for shares etc.)...

1.) In Windows Explorer, from the tools menu, select "Map Network Drive...".

2.) Select an appropriate drive letter and enter the path to the shared resource (\\machine\share).

3.) And here's the trick... Click on "Connect using a different user name.

4.) You'll notice that the Connect As... dialogue indicates the default username that will be used - probably the same name as your user folder under Documents and Settings. Enter the correct username and password for this shared resource and you should be networking happily.

Note: If you're not using DHCP with a DNS on the network, a suitably written hosts file in \<WIN>\system32\drivers\etc can help speed up finding shared resources.

Happy networking
http://www.ddc.co.za/

#34 Guest_Vorhenze_*

Guest_Vorhenze_*
  • Guests

Posted 10 February 2004 - 09:54 PM

matterdaddy.com...

THANKS. I knew this solution you mention had solved my problem in that past, but I lost that link. I just spent an hour trying to find this solution again. And it worked again!

#35 Guest_terahari_*

Guest_terahari_*
  • Guests

Posted 27 February 2004 - 11:49 PM

I am not sure if Larry got his problem resolved.

I had been having similar problems. Finally I figured out that my antivirus is the cause of the problem.

My antivirus was configured to run Firewall and holding all the networking packets. When I stopped the firewall I was able to access my network without any problem.

My Antivirus program is PC-Cillin 2000.

Good luck.

Terahari

#36 Guest_terahari_*

Guest_terahari_*
  • Guests

Posted 27 February 2004 - 11:51 PM

This is a followup to my earlier posting. Stop all the firewalls and see if this fixes the problem.

Hari

#37 Guest_John Rigali_*

Guest_John Rigali_*
  • Guests

Posted 15 March 2004 - 11:25 AM

I had this problem once. I had to enable the Guest user account on each PC that was sharing resources (files and/or printers) to eliminate the problem.

Several of you seem to have abandoned your firewall software. It seems that you were daunted by network problems, and figured that firewalls just aren't worth the hassle. They are. Let me give you a little guidance:

1) Set up your network first, and prove to yourself that it's fully functional. If any of your PCs have firewall software already, disable that software until full network functionality is proven.

2) Deploy your firewall software on one PC at a time, and ensure that it is properly configured on that PC before deploying on the next one. If any of your PCs had firewall software before you got to this step, enable that software on one PC at a time, ensuring that each PC's firewall is properly configured before moving on to the next one. It's very difficult to troubleshoot network problems when one has two or more PCs with improperly configured firewalls (and this is exactly what some of you encountered).

Personally, I don't like the Internet Connection Firewall built into Windows XP. It can't be configured to suit one's needs or wants. Because it doesn't generate any reports, its effectiveness can't thoroughly be known. I use and recommand the ZoneAlarm family from Zone Labs:

A) It has an intuitive and uncluttered interface.
B) It can be installed and configured relatively quickly.
C) It generates an activity report so that one can see what is blocked and what is allowed.
D) It monitors outbound traffic (which can be generated by viruses and spyware) as well as inbound traffic -- the mark of a good firewall.
E) It can be configured to automatically check for updates, upon which it notifies the user.
F) It is rated the best family of personal firewalls by more IT reviewers and pundits than any other family of personal firewalls.
G) There is a free edition for personal use.

That's my two cents' worth.

jarigali at bigfoot.com

#38 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 23 March 2004 - 04:30 PM

Install a PORTOCAL call NWlink ????????
and it will solve...

#39 rambler

rambler

    Newbie

  • Members
  • Pip
  • 10 posts

Posted 25 March 2004 - 03:04 PM

On a network with only one internet-connected PC, a firewall is only needed on THAT PC. When you're at home the only door you need to have locked is the outside one. You don't lock the internal doors as well. Internal firewalls are not only unnecessary, they'll wreck your networking. If you have a modem connected via a router, the router will have a hardware firewall, and in that case you don't need a software firewall on ANY of the PC's.

#40 Guest_Willie Wheeler_*

Guest_Willie Wheeler_*
  • Guests

Posted 27 March 2004 - 02:57 PM

Hey all--I was having the same problem as everybody is describing. The thing about changing the node type from Peer-to-Peer to Hybrid worked for me. (Nothing else did. I'm not running a firewall; I had accounts on both machines; etc.) Hooray for CMU! :P